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Introduction and Installation

Welcome to MediaMaestro!
MediaMaestro is a multimedia presentation software that lets you create
full-featured interactive multimedia presentations for personal, business
and home office use. Make impressive presentations containing video, 
animation, images, text, sound and music.

MediaMaestro is intuitive and easy to use. The drag and drop interface 
lets you put stunning presentations together in just minutes. Interactive 
presentations can be created for use in point of sale, training etc.

Standard business presentations can be made more interesting by 
adding video sequences and still images along with text, sound and 
music. Video formats supported include AVI, MPEG and DAT (Video CD). 
Image formats supported are BMP, TIF, PCX, JPEG and Photo CD. Sound 
and music files in WAV, MIDI and CD Audio format can be added to 
presentations.

A flexible text function, screen underlays, transition effects, pre-defined 
templates and backgrounds, ready-made sample presen-tations as well 
as a complete media clip library are included in MediaMaestro.

A run-time version of MediaMaestro is provided for distribution with 
presentations.

Contents of the MediaMaestro CD
Included on the MediaMaestro CD are:
- The MediaMaestro program 
- MediaMaestro Run-time player
- Licence free media clips in a variety of formats for use in 
MediaMaestro
- License free photographic images
- Sample presentations
- User tutorial made with MediaMaestro

System Requirements
Hardware
Minimum:
80386/SX IBM PC compatible computer
4 MB RAM
Hard disk with 10 MB free disk space
VGA/Super VGA graphics adapter card
Windows-compatible mouse or other pointing device
Double-speed CD-ROM drive

Recommended:
80486 / 66 MHz IBM PC compatible computer
8-16 MB RAM
Hard disk with 50+ MB free disk space
Hi-color or true color graphics adapter card



Windows-compatible mouse or other pointing device
Double-speed CD-ROM drive
To take advantage of MediaMaestros multimedia functionality, the 
following optional hardware is recommended:
-   Windows compatible sound card
-   MPEG decompression board

Software

MS-DOS 3.1 or higher
Microsoft Windows 3.1 or higher

MCI (Media Control Interface) drivers for:
- all installed optional hardware 
- CD Audio
- Video for Windows *
- Autodesk Animator *
- MIDI
* provided on the MediaMaestro CD in the Driver directory.
Some drivers, such as the CD Audio driver, are provided with Microsoft 
Windows. Other drivers which are hardware specific, such as the MIDI 
driver, are provided when you purchase a sound board.

Installing MediaMaestro
The MediaMaestro CD contains the MediaMaestro program and a variety
of sample media clips and photographic images. During the installation 
procedure, only the MediaMaestro program (and run-time player) will be
installed to your hard disk. 

To save space on your hard disk, sample media clips will not be copied 
during the installation procedure. They can be accessed directly from 
the CD or copied selectively to the hard disk when creating 
presentations in MediaMaestro.
To install MediaMaestro onto the hard disk:

1. Insert the MediaMaestro disc into the CD-ROM drive.
2. From the Windows Program Manager, select Run from the File 

menu. In the Run dialog box, type d:\software\setup.exe. Click on 
OK.
Note:
d: is the location of the CD-ROM drive and may vary depending on 
your system configuration.

3. The Setup program will appear on the screen.
4. Select the destination path where you want to install MediaMaestro 

by typing in the text box. Alternatively use the default destination 
path c:\maestro.

5. Select the software modules you want to install or use the default 
settings.

6. Select the language the software should be installed in by making 
the appropriate selection from the Language list box.

7. If a Windows program group should be automatically created during
installation, click on the Build program
group check box.

8. Click on the Install button to begin the installation procedure.



9. If Build program group was selected, the MediaMaestro program 
group appears on the screen when installation is complete.

User Documentation / Tutorials
More detailed information on how to use MediaMaestro to create fast 
and exciting presentations is provided in:

- this manual in the section entitled Creating Multimedia
 Presentations with MediaMaestro
- the MediaMaestro Tutorial on the MediaMaestro CD
- the sample presentations on the MediaMaestro CD
- the online Help file
- the online Manual file.

Playing Media Clips in MediaMaestro
You can use many different multimedia components such as video, 
sound, music, images and text in MediaMaestro to create exciting and 
interesting presentations. 

MediaMaestro supports some multimedia components through 
hardware. Two examples of multimedia hardware are sound boards for 
playing sound and music files or MPEG decoder boards for playing full 
screen, full motion MPEG video or Video CDs.

A software device driver which is installed through the Windows Control 
Panel is required to communicate with such hardware components.

Note:
Make sure all hardware and associated drivers are installed correctly 
before creating presentations with MediaMaestro.

Other media types, such as Autodesk Animator and Video for Windows 
files are supported by a standard Windows MCI driver. The appropriate 
MCI driver must be installed before the media type can be played in 
MediaMaestro. 

Note:
To find out which MCI drivers are installed on your computer system, 
double-click the Drivers icon in the Windows Control Panel. A list box will 
appear displaying all drivers which are currently installed. To install any 
drivers which may not already be installed on your system, refer to the 
appropriate section in your Microsoft Windows Users Guide.

Creating Multimedia Presentations with 
MediaMaestro

Presentation Basics
The steps to follow when planning a multimedia presentation are to:
- Target your audience
- Decide on the message you want to get across with your presentation



- Locate the appropriate media in the form of videos, images and
 sound which will help you get your message across
- Make a rough draft of any text you might want to add to the 
presentation
- Select a basic template style for the presentation

To create multimedia presentations in MediaMaestro you will be working 
with four main windows:

-  the Presentation window
-  the File Selector window
-  the Edit Frame window
-  the Organization window

The Program Window 
First of all, start by opening the main program window. To do this, 
double-click the MediaMaestro program icon in the MediaMaestro 
program group in the Windows Program Manager.

Creating a Simple Presentation
The followings steps show how to create a simple presentation:

1. Select New from the File menu.
2. A new Presentation window will appear on the screen. The filename 

[Untitled] 
will appear in the Presentation window title bar.

3. Select File Selector from the File menu.
4. Select the files you want to include (e.g. TIFF image files or Photo 

CD images) 
with the help of File Type, Drive, Directory and File Format. 

5. An overview of all selected files available will be shown. The files 
are either displayed as thumbnail images ( Photo CD format only) or
as bitmaps representing the file and file type.

6. Select Tile horizontally from the Window menu.
7. Choose Select All from the Edit menu or make a selection with the 

mouse.
8. All selected files will be displayed highlighted to show that they are 

selected.
9. Drag and drop the selection onto the Presentation window. A new 

frame for each image will be created.
10. Click on the Link button. The Link dialog will appear.
11. Select all the entries under Frames and click on the Add button. All 

selected frames will be added to the Play List. Accept the selection 
with OK.

12. Click on the Play button to view the presentation. 

Creating a Simple Interactive Presentation
The followings steps show how to create a simple interactive 
presentation: 

1. Select New from the File menu or click on the New icon.
2. A new Presentation window will appear on the screen. The filename 

[Untitled] will appear in the Presentation window title bar.



Note: 
The Properties dialog will appear automatically when a new frame is
created if this setting is activated in the Program Settings dialog 
box. It is set to on as a default when MediaMaestro is first installed. 
If it is not set to on as a default, you can manually select each 
frame and rename them as desired using the Properties icon on the 
tool panel.

3. Select File Selector from the File menu or click on the File Selector 
icon.

4. Select the files you want to include (e.g. TIFF image files or Photo 
CD images) with the help of File Type, Drive, Directory and File 
Format. 

5. An overview of all selected files available will be shown. The files 
are either displayed as thumbnail images (only Photo CD format) or 
as bitmaps representing the file and file type.

6. Select Tile horizontally from the Window menu.
7. Choose Select All from the Edit menu or make a selection with the 

mouse.
8. All selected files will be displayed highlighted to show that they are 

selected.
9. Drag and drop the selection onto the Presentation window. A new 

frame for each image will be created.
10. Double-click on the first frame. The Edit Frame window will be 

opened.
11. Create two buttons with the Button tool and move the buttons to 

the desired location.
12. Use the Text tool to put a name onto the buttons, e.g., Start and 

Quit.

Note:
The text or image which is placed on top of a button must always 
be inside the frame of the button. If not, it will not be recognized as 
a button.

13. Use the Edit tool to change the title of the buttons accordingly. The 
titles Start and Quit should now appear in the Item List at the left 
side of the Edit Frame window.

14. Close the Edit Frame window. The frame will display a key symbol to
show that it is a control frame.

15. Drag and drop the edited control frame onto the Organization 
window.

16. Select the Start button in the Organization window.
17. Click on the Link button. The Link dialog will appear.
18. Select one or all entries under Frame and click the Add button. The 

selected frame will be added to the Play List for the selected 
button. Select the entry <Exit> in the Play List and click the Clear 
button. The entry will be removed from the Play List. Accept the 
selection with OK.

Note: 
Alternatively you can drag and drop frames from the Presentation 
window directly into the Organization window.

19. Double-click the Quit button in the Organization window. The 
<Exit> symbol will be displayed.

20. The presentation structure in the Organization window should look 
like this:



21. Click on the first item in the list in the Organization window. Click on the Play button
to view the presentation.

Note:
When you click on the Play button, the show will start playing from 
the selected item in the Organization window. This makes 
previewing a specific segment of a presentation possible.

Creating a Complex Interactive Presentation
The followings steps describe how to create a more complex interactive 
presentation. In this exercise  you will learn how to create several levels 
of interactivity and how to use some of the functionality of 
MediaMaestro such as text, effects and adding sound and video to 
frames.

1. Select New from the File menu or click on the New icon.
2. A new Presentation window will appear on the screen. The filename 

[Untitled] will appear in the Presentation window title bar.
3. Click on the New Frame icon twice to create two new frames.
4. The Properties dialog will appear automatically each time a new 

frame is created. Rename the first frame to Intro and the second 
frame to Main Menu.
Note: 
The Properties dialog will appear automatically when a new frame is
created if this setting is activated in the Program Settings dialog 
box. It is set to on as a default when MediaMaestro is first installed. 
If it is not set to on as a default, you can manually select each 
frame and rename them as desired using the Properties icon on the 
tool panel.

5. Double-click the Intro frame. The Edit Frame window will appear.
6. Click on the Text icon. Enter the text MediaMaestro in the text box. 

Select a size and font for the text. In the Color and Frame dialog 
box, choose the color red for the text. Click on OK.

Note:
When adding text to a frame, it can be displayed as either 
transparent or opaque. With the text block active, select 
Transparent from the list box underneath the Item List. 
Alternatively, leave the text as opaque but make sure that the 
background color of the text block is the same color as the 
background of the frame.

7. Using the Load Image icon, load the file butt_11.tif from the Buttons
directory on the MediaMaestro CD. Move it to the desired location 
on the frame.

8. Click on the Button icon to add a button to the frame. Place it on 
top of the arrow image which was just loaded into the frame. Resize
the button if necessary to fit on top of the image. With the button 
selected, click on the Edit icon to open the Button Settings dialog. 
In the text box under Title enter the text Forward. On the left hand 
side of the dialog box, select Color and Frame. Change the setting 
under Frame Size to 0. Click on OK.

9. The name of the button now appears in the Item List as Forward.



Note:
It is advisable to rename buttons so that they can be more easily 
linked in the Organization window when the final presentation is 
created.

10. With the button selected, click on the Opaque/Transparent list box 
on the left hand side of the Edit Frame window. Select Transparent. 
The button is now transparent on top of the arrow.

Note:
Using this method it is possible to create transparent buttons with 
any type of photo, graphic or text.

11. Create a second button and move it to the desired location. 
Rename the button to Exit using the method described under point 
7.

12. Click on the Text icon. Enter the text Exit in the text dialog and 
select the desired font, size and color. Click on OK. Place the text on
top of the Exit button.

13. Click on the Next button to go to the next frame.
14. The frame entitled Main Menu will appear.
15. Click on the Text icon. Enter the text Create dazzling multimedia 

presentations with in the text box. Select a font, size and color for 
the text. 

16. Click on the Button icon to add a button to the frame. Move it to the
desired location. Rename the button to Images using the method 
described previously. Click on OK.
The name of the button now appears in the Item List as Images.

17. Click on the Text icon. Enter the text Images + Sound in the text 
dialog and select the desired font, size and color. Click on OK. Place 
the text on top of the Images button.

18. Click on the Button icon to add a button to the frame. Move it to the
desired location. Rename the button to Video using the method 
described previously. Click on OK.
The name of the button now appears in the Item List as Video.

19. Click on the Text icon. Enter the text Video + Animation in the text 
dialog and select the desired font, size and color. Click on OK. Place 
the text on top of the Video button.

20. Create another button and rename it to Exit using the Edit dialog.
21. Click on the Text icon. Enter the text Exit  in the text dialog and 

select the desired font, size and color. Click on OK. Place the text on
top of the Exit button.

22. Double-click the Close box on the Edit Frame window or select Close
from the File menu to close the Edit Frame window.

Note:
When frames contain buttons they are referred to as control frames.
On the Presentation window they are displayed with a key symbol in
the upper right hand corner to show that they are control frames.

23. Click on the Save icon to save the presentation to the hard disk. 
Enter a filename and location where the presentation should be 
saved.

24. Select File Selector from the File menu or click on the corresponding
icon.

25. Select the files you want to include, in this case TIFF image files  
from the MediaMaestro CD with the help of File Type, Drive, 
Directory and File Format. 



26. An overview of all selected files available will be shown. 
27. Select Tile horizontally from the Window menu.
28. Select 6 images from the File Selector window.
29. All selected files will be displayed highlighted to show that they are 

selected.
30. Drag and drop the selection onto the empty space on the 

Presentation window beside the two existing control frames. A new 
frame for each image will be created.
Rename each of the 6 frames to Image 1, Image 2, Effects 1, Effects 2, Effects 3 and 
With Sound.

31. Double click the frame Image 1 to edit. Add the text Images using 
the text icon. Resize the image to the desired size. Close the Edit 
Frame window.

32. Double click the frame Image 2 to edit as desired.
33. Add two buttons and rename them to Effects and Back using the 

method as described previously. Add text for Effects and Back on 
top of each button.

34. Close the Edit Frame window.
35. Double click the frame Effects 1 to edit. Add the text Random Fade 

using the text icon. Click on the Up arrow to move the text item to 
the top of the Item List.

36. Select the image in the frame. Click on the Effects list box and 
select the effect Random fade.

37. Click on the Preview icon to preview the entire frame.
38. Close the Edit Frame window.
39. Double-click the Effects 2 frame to open. Add an effect and the 

corresponding text to the frame. Close the frame.
40. Double-click the Effects 3 frame to open. Add an effect and the 

corresponding text to the frame. 
41. Add 2 buttons to the frame and rename them to Sound and Back. 

Add the appropriate text on top of the buttons. Close the frame.
42. Double-click the With Sound frame. Add an effect and 

corresponding text to the frame.
43 Using the Sound icon, select a .wav file from the MediaMaestro CD. 

Click on OK.
44. With the WAV file selected in the Item List, click on the View icon to 

preview the sound only. Alternatively, use the Preview icon to 
preview the entire frame if desired. 

45. Close the frame.
46. If the File Selector window is not already open, select File Selector 

from the File menu or click on the corresponding icon.
47. Select the files you want to include, in this case AVI or MPEG video 

files with the help of File Type, Drive, Directory and File Format.

Hint:
With a video file selected on the File Selector window, click on the 
Preview button. Click on the Play button to preview the item to 
make sure it is the one you want before putting it in your 
presentation. 

48. Select one video file from the File Selector window and drag and 
drop the selection onto the Presentation window. A new frame will 
be created. Rename the frame to Video.

49. From the File Selector window, change the settings to locate the  FLI
animation files on the MediaMaestro CD. 

50. Select the desired file and drag and drop it onto the Presentation 
window. Rename the frame to Animation.

51. Edit both the Video and Animation frames to include the 
appropriate text in each frame as described previously.

52. Save the presentation again to the hard disk.



Note:
Using the basic methods as outlined above, any kind of complex 
presentation can be created with MediaMaestro. Many other 
functions are available in MediaMaestro which could not be 
described at length in this manual. For example, interesting 
presentations can be made using templates, underlays, CD Audio 
and the wide variety of video, image and sound formats which are 
supported. The only limitation is your imagination!

Now that the individual frames are finished, its time to put them 
together into a presentation Play List.

The Organization Window
To create the presentation and the links for the buttons which were 
added to some frames, a Play List is created in the Organization window.

There are two methods which can be used to add frames to the 
Organization window:

1. Dragging and dropping them to the desired location.
2. Using the Links dialog box.

Note:
When deleting items from the play list, you must use the Links 
dialog box!

The Play List is displayed in the Organization window in a tree structure. 
The links created by linking frames to control frames are called 
branches.

When a control frame containing buttons is dropped into the 
Organization window from the Presentation window, the new branch is 
displayed closed. You must then double-click the appropriate button to 
open the next branch.

Creating the presentation play list:

1. Maximize the Presentation window by clicking on the Maximize 
button on the top left hand corner of the title bar. Make the 
Organization window wider by clicking on the right hand side of the 
window and dragging it to the right. 

2. Select the frame Intro on the Presentation window. Drag and drop it 
into the Organization window.

3. The two buttons on the Intro frame will appear. Double-click the Exit
button to open. The Exit symbol will appear showing that when this 
button is clicked during the presentation, the presentation will be 
terminated.

4. Drag and drop the Main Menu frame onto the Forward button.
5. Double-click the Forward and Main Menu buttons to open. Under 

Main Menu you will see three buttons Images, Video and Exit.
6. Double-click the Images button to open. 
7. Drag and drop the frames Image 1 and Image 2 onto the Images 

button on the Organization window.
8. Double-click the Images 2 button. The buttons Effects and Back will 

appear.
9. Double-click the Back button. Click on the Links icon. The Links 

dialog box will appear. Under Play List select Exit and click on Clear. 
Under Return Frames select Main Menu and click on the Add button.



Click on OK. The return symbol with the name Main Menu will 
appear in the Organization window.

10. Double-click the Effects button. Drag and drop the frame Effects 1 
onto the Effects button. Drag and drop the frames Effects 2 and 
Effects 3 underneath Effects 1.

11. Double-click the Effects 3 button to open. Two buttons Sound and 
Back will appear.

12. Double-click the Sound button. Drag and drop the With Sound 
frame onto the Sound button.
Note:
Also under the Sound button you will see the Exit symbol. This must
be removed as otherwise the presentation would terminate after 
playing the With Sound frame.

13. To remove the Exit symbol, make sure the Sound button is selected and click on the 
Links icon. The Links dialog box will appear. Under Play List select Exit and click on
Clear. This means that after the frame is played, you will be returned back up the tree 
to the Main Menu frame. Click on OK to exit the dialog box.

14 Double-click the Back button. Modify the link to the Return Frame as
described under point 9.

15. Double-click the Video button to open. 
16. Drag and drop the frames Video and Animation onto the Video 

button on the Organization window.
17. With the Video button selected, click on the Links dialog. Remove 

the Exit entry from the Play List area in the dialog box and click on 
OK.

Now that the play list is ready, its time to play the presentation. Save 
the presentation once again to the hard disk before continuing.

18. Click on the first item in the list in the Organization window. Click on
the Play button to view the presentation.
Note:
It is possible to preview any sequence of a presentation by selecting
the frame where the presentation should start playing. Click on the 
Play icon to start the presentation. Use the Esc key to stop the 
presentation when youve previewed the desired sequence.

19. Go through the presentation while it is playing to check that the 
order and the links are the way you want them. 

20. Make any necessary corrections before compiling the presentation.

Playing Sound and Music in MediaMaestro
Adding sound and music can make presentations more effective and 
interesting. Sound and music files in the form of  Wave, Midi or CD Audio
can be included in presentations either as foreground music or 
background music. 

For example, you might like to include some sound effects to more 
effectively demonstrate an idea or have a CD Audio track playing in the 
background while your presentation is running.

Playing foreground sound or music
A sound or music track marked as a foreground sound will be played in 
the order set by the Item List of the current frame. It will not be 
interrupted by any other item of the current frame. 



To insert foreground sound or music:

1. Open a frame of the current presentation.
2. Insert Sound or Music with the Sound, Midi or CD Audio button.
3. The name of the sound will appear in the Item List.
4. Open the Audio Settings Dialog by clicking on the Edit button.
5. Change the audio settings as desired and activate the check box 

Play in foreground.

Playing background sound or music
A sound or music track marked as a concurrent background sound will 
start as defined in the Item List of the current frame. It will then go on 
playing while the other items of the current frame are simultaneously 
being shown or being played. A background sound will not stop if the 
user clicks a button or when the presentation switches to another frame.

To insert background sound or music:

1. Open a frame of the current presentation.
2. Insert Sound or Music with the Sound, Midi or CD-Audio button.
3. The name of the sound will appear in the Item List.
4. Open the Audio Settings Dialog  by  clicking on the Edit button.
5. Change the audio settings as desired and deactivate the check box 

Play in foreground.

Playing background and foreground sound or music
The concept of background and foreground sound allows music to be 
played in the background while simultaneously showing or playing a 
foreground sound or other events.

A background sound always has higher priority than a foreground sound 
of the same type. If, for example, a Midi file is being played as a 
background sound, any concurrent Midi foreground music will be 
ignored. However, a concurrent Wave file will be played.

The following table provides an overview of background and foreground 
sound combinations. Due to different hardware configurations, the 
results might differ slightly.

Background Sound Foreground Sound Plays 
Foreground Sound

Wave File Wave File No
Midi File Yes
CD-Audio Yes
Video / AVI No
Video / MPEG  Yes

Midi File Wave File Yes
Midi File No
CD-Audio Yes
Video / AVI Yes
Video / MPEG  Yes

CD-Audio Wave File Yes
Midi File Yes
CD-Audio No
Video / AVI Yes
Video / MPEG    No



Stopping background sound or music
A background sound can only be stopped by another background sound,
regardless of the sound file format. Thus, the best way to stop a 
background sound is to play a very short background Wave file. Such a 
file named ZERO.WAV is provided on the MediaMaestro CD.

Printing Your Presentation
When your presentation is complete, you might want to print out the 
entire presentation or individual frames onto paper or overhead 
transparencies.

With MediaMaestro you can print to any color or monochrome printer 
which is installed under Microsoft Windows. 

Printing frames which contain large images or gradients can be time 
consuming - especially if you are printing a color frame onto a 
monochrome printer.

Note: 
Some colors used for text input may not be visible when printing to a 
monochrome printer.

To print an individual frame:

1. With a presentation open in the MediaMaestro program window, 
select the frame you want to print.

2. Click on the Print icon on the Tool Bar or select Print from the File 
menu.

3. The Print dialog box will appear. Make the desired settings such as 
orientation on the page and the number of copies and click on OK.

Note:
To print all slides in a presentation, choose Select All from the Print 
dialog box.

Compiling Presentations in MediaMaestro
Once your presentation is complete it can be compiled for distribution 
on CD-ROM or on a network drive. Many options are available for 
optimizing the way a presentation is displayed on screen.

By selecting the option Copy Run-time Player to Central Directory the 
run-time version of MediaMaestro is copied to the central directory so 
that the compiled presentation can be played on any computer system. 

The options in the Compile dialog box can be described as follows:

Copy Media Files to Central Directory
If this option is switched on, all media files are copied to the central 

directory.

Note:
Due to the structure of CD-Audio tracks and Video CD (.DAT) files, 



these media items cannot be played from a hard disk or over a 
network. These items will not be copied and will be referred to only 
by reference in a compiled presentation.

Copy Run-Time Player to Central Directory
If this option is switched on, the run-time player is copied to the 

central directory.

Note:
The run-time player SHOWPLAY.EXE requires the following 
files:CTL3D.DLL, PCDLIB.DLL, PVIMGLIB.DLL, SPLIB.DLL. These files 
will automatically be copied if this option is switched on during 
compilation.

Maintain Subdirectories
If this option is switched on, subdirectory structures containing 
media files are copied to the central directory. 

Maintain References to first CD-ROM Drive
If this option is switched on, media files on the first CD-ROM drive 
are not copied to a central directory. These files will be referred to 
only by reference in a presentation.

Note:
Use this option if you are using a lot of resources from a CD-ROM 
and/or you have little space left on your hard disk drive.
If the compiler option Compile Bitmaps and copy to Central 
Directory is switched on, image files on the CD-ROM will 
nevertheless be compiled and copied to the central directory.

Central Directory
This field allows you to set the central directory the compiled 
presentation will be copied to.

Compile Gradients and copy to Central Directory
If this option is switched on, underlays containing gradients will be 
saved as image files which will speed up the display of gradients 
during a presentation.

Compile Bitmaps and copy to Central Directory
If this option is switched on, bitmaps will be saved as image files in 
the size defined in the presentation which will speed up the display 
of image files during a presentation.

Encrypt Presentation
If this option is switched on, all media files which are to be copied to
the central directory will be given encrypted names.

Loop
The Loop option is used to play a presentation continuously. It is not
possible to stop such a presentation even if you click on a button 
which includes the Exit command.

Note:
If the compiler option Allow Escape is switched on, such a 



presentation can be stopped using the ESC key.

Allow Escape
If this option is switched off, it is not possible to stop a presentation 
using the ESC key command. The presentation can only be stopped 
if you click on a button which includes the Exit command.

Note:
When this option is switched off, hitting the ESC key will escape out
of the current sequence in a frame and will go on to the next frame.
This is useful if you want to break out of a video sequence, for 
example.

Colors
This option allows you to set the type of a compiled presentation. 
Depending on the selected color type, images and underlays will be
saved in the appropriate format. The available settings are:
All,16 Colors, 256 Colors, Full Color.

Note:
Use the 256 Colors setting to save loading times and disk space.

Use the All setting if you dont have any information about the 
systems the presentation will be shown on, or if you want to provide
the best quality possible.

Note:
A specific compiler setup creates presentations which are usually 
faster and more compact than the universal ones. However, as 
these presentations are made for a specific screen mode, they 
might not look and work as well on systems with different color 
settings or screen resolutions.

Size
This option allows the screen size of a compiled presentation to be 
set. Depending on the selected screen size, media items will be 
scaled and saved in the appropriate format. The available settings 
are:
All, 640 x 480, 800 x 600, 1024 x 768, 1280 x 960 

Note
Using the 640 x 480 to 1280 x 960 settings will speed up the presentation as long as 
the screen resolution matches the presentation size. The All setting will scale a 
presentation for any screen resolution. 
Use the All setting, if you dont have any information about the 
systems the presentation will be shown on, or if you want to provide
the best quality possible.

Examples of Compile Options
What compiler options should be used to achieve the best results?

Example 1:
Use these compile options when the presentation will be played on 
the same machine that it was created on.



-  Copy media files to Central Directory
-  Compile Gradients and copy to Central Directory
-  Allow Escape
-  256 Colors, 640 x 480

Note:
Depending on your hardware configuration and the amount of hard 
disk space available, you might want to change the color and size 
settings accordingly. For example, if your graphics adapter supports 
full color, you might want to compile the presentation with the color
option set to Full Color.

Example 2:
Use these compile options for best results when the target system 
that the presentation will be played on is unknown.

-  Copy media files to Central Directory
-  Copy Run-time Player to Central Directory
-  Compile Gradients and copy to Central Directory
-  Compile Bitmaps and copy to Central Directory
-  Allow Escape
-  256 Colors, All

Example 3:
Use these compile options when the presentation will be played at a
trade show or other public event

-  Copy media files to Central Directory
-  Maintain reference to first CD-ROM drive
-  Copy Run-time Player to Central Directory
-  Compile Gradients and copy to Central Directory
-  Compile Bitmaps and copy to Central Directory
-  Encrypt Presentation
-  256 Colors, 640 x 480

Note:
Depending on your hardware configuration and the amount of hard 
disk space available, you might want to change the color and size 
settings accordingly. For example, if your graphics adapter supports 
full color, you might want to compile the presentation with the color
option set to Full Color.

The MediaMaestro Run-time Player
The run-time player allows you to play a compiled presentation. As the 
run-time player is a license-free product, presentations can be created 
and compiled with MediaMaestro and distributed as run-time versions 
together with the player.

The run-time player automatically starts a presentation with the 
filename AUTOSTAR.ODC as long as the run-time player and the 
presentation are in the same directory. If the run-time player does not 
find this presentation, the Open dialog will appear. Select the drive and 
directory to load the file of your choice.



Reference
Provided in this section of the manual is more detailed information 
about each of the windows that you will be working with in 
MediaMaestro.

The Program Window 
The MediaMaestro program window consists of the title bar, the menu 
bar and the tool panel. 

The tools on the tool panel can be described as follows:

File Selector
The File Selector window provides an overview of all files in a selected 
directory.

New
Creates a new presentation window.

Open
Opens an existing presentation from any drive or directory.

Save
Saves the current presentation to disk using the existing filename.

Print
Prints the selected frame to the installed printer.

Information
Provides useful information such as the number of frames or control 
frames, file name, path name or file size of the current presentation as 
well as system information.

Program Settings
Allows configuration of general program settings and options which will 
take effect on startup of the program.

The Presentation Window
The Presentation window provides the tools and the workspace to create
and organize frames within a presentation.

The tools on the tool panel are used to create and edit frames within a 
presentation and can be described as follows:

New
Creates a new frame.

Edit
Opens the selected frame for editing.

Properties
Displays a text box for renaming a frame or changing the background 
color.



Copy
Copies a frame for pasting to a new location on the Presentation window
or to another presentation.

Cut
Removes a frame from the Presentation window which can then be 
pasted to another location in the current window or to another 
presentation.

Paste
Pastes a frame which has been either copied or cut to another location 
in the current window or to another presentation.

Clear
Permanently removes a frame from the Presentation window.

Template
Lets you select a frame as a template for the creation of new frames.

Use Template
When this check box is selected, the current template will be used when
new frames are created.

The Organization Window
The Organization window is used to organize the internal structure and 
flow of control of a presentation.

The control buttons on the bottom of the Organization window are used 
to control how a presentation is played. The functionality of the buttons 
can be described as follows:

Link
The Link button is used to create a presentation or to modify a 
presentation by linking buttons on control frames to other frames of  the
presentation.

Loop
The Loop option is used to play a presentation continuously until it is 
manually stopped.

Sound
This option is used to turn the sound On or Off during a presentation.

Play
This option starts the presentation which is defined in the current 
Organization window.

The File Selector Window
The File Selector window provides an overview of existing files you 
might want to select and include in your presentation.

There are four selection boxes and a Preview button on the File Selector 
window which can be described as follows:

File Type selector
Allows you to choose the file type - image, sound, video or all.



Drive selector
Allows you to choose the disk drive you want to load files from.

Directory selector 
Allows you to choose the directory or subdirectory you want to loadfiles 
from.

File Format selector 
Allows you to choose among several multimedia file types depending 

on the File Type selected.

Preview
Allows you to preview a selected file.

 
Hint: 
Double-click a file to open the Preview window.

Single or multiple files can be selected on the File Selector window 
which will then be dragged and dropped into the Presentation window. 
This is the fastest and easiest way to include all file types into a 
presentation.

Selecting Files on the File Selector Window
To select a single file
Click on the desired file once with the mouse. It will appear dark gray to 
show that it is selected.

To deselect a file
Holding the Ctrl button down, click on the file to be deselected.

To select multiple files
Use Shift + Click to select a range of files.
Use Ctrl + Click to select individual files.
Draw a selection box with the mouse around any number of files.

To select all files
Choose Select All from the Edit menu.

To deselect files
Chose Deselect from the Edit menu.

Note:
It is not possible to preview multiple files!

The Edit Frame Window
The Edit Frame window provides the necessary tools and the workspace 
to create and edit the events of a single frame.
The Tool Bar 
The Tool Bar provides the basic tools to create and edit events within a 
frame.



Copy 
Copies a selected item for pasting to a new location in the frame or to 
another frame.

Cut
Removes a selected item which can then be pasted to another location 
in the current frame or to another frame.

Paste
Pastes a selected item which has been either copied or cut to another location in the current
frame or to another frame.

Clear
Permanently removes a selected item from the frame.

Text
Insert text in the frame.

Button
Place buttons in the frame to create an interactive presentation.

Underlay
Put an underlay in the frame.

WAV
Insert sound and music in the .wav format.

MIDI
Insert music in the .mid format.

CD Audio 
Insert a CD Audio music clip.

Images
Add image files.

Video
Insert video clips.

Animation
Insert Autodesk Animator animation clips.

Timer
Add a timer into the presentation.

Previous Arrow
Go to previous frame.

Preview Frame
Make a preview of the frame.

Next Arrow
Go to next frame.

Move to front
Move media item to front.



Move 1 step to front
Move media item one layer forwards.

Move 1 step to back
Move media item one layer backwards.

Move to back
Move media item to back.

The Item List
All media items in a frame are included in the Item List. The order in 
which they appear in the item list is the order in which they will appear 
on the screen when a presentation is played.

Hint: 
To manually move a media item within the Item List, use the Move to 
front and Move to back buttons.

The Effects List Box
Special effects can be given to items of a frame such as images or text 
by using the options available in the Effects list box.

The following effects are available:
Display Mode:

Transparent
Opaque

Effects:
No effect
Random fade
Wipe left, Wipe right,Wipe up, Wipe down
Zoom in, Zoom out
Turn down, Turn up
Vertical split in, Vertical split out
Horizontal split in, Horizontal split out
Scroll down, Scroll up
Scroll left, Scroll right, 
Wipe diagonal
Diagonal zoom in

Color Settings
Color, background color, frame size or shadow of an item can be 
changed by using the Color Settings. The following tools are available:

Color Indicator
The Color Indicator allows you to change the color settings of an item. 
Click on the part or attribute you want to change and set the color using
the Color Palette.

Color Palette
The Color Palette allows you to set the color of an items part or 
attribute. Click on the part or attribute you want to change and set the 
color using the Color Palette. 

Hint:
To make a custom color, double-click a color in the color palette. A 
dialog box will appear where you can mix your custom color.



Additional Tools
Snap to Grid
The Snap to Grid tool helps to precisely place and resize items in the 
Edit Frame Window. To select the distance between grid points, make 
the appropriate selection under Program Settings > Other.

Edit
The Edit tool lets you view and edit the settings of a single item in the 
Edit Frame window. Depending on the item type, the Edit dialog offers a 
variety of editable settings.
For example, for all items which can be added into a frame, the 
following settings can be made:

Area + Title
Title:

Enter a name, other than the default name, for the item.
Area:

Enter the exact coordinates for the location of the item.
Shadow Offset:

Define the amount of shadow if a shadow should appear on the 
item. 

Color + Frame
Frame Size: 
Enter the frame size.
Color Type:
Select colors for item, background, shadow and frame.
Available Colors:
Displays the color palette for the choices made under color type.

View
The View tool lets you preview a single item in the Edit Frame window.

Media Information
Useful information such as filename, path name, file size or media type 
of the selected item is provided.

Previewing and Making Selections of Media Items
For each item type which can be added into a frame, specific settings 
can be made. For example, if you want to see a preview or make a 
selection of a music or video clip, it can be made in the Settings dialog 
box.

In this dialog box you can preview the video clip or make a selection to 
be included in your presentation.

To make a selection of a media clip:

1. Click on a media item in the Item List or on the frame window.
2. Click on the Edit button to open the Edit dialog box.
3. If a video clip was selected, the Video Settings dialog box will 

appear.
4. Use any of the control buttons to play, stop or pause.
5. Make a selection of the clip by clicking on the slider bar underneath 

the time display. Holding the mouse button down, slide the bar in 



the desired direction. Do this on one or on both ends of the video 
clip.

6. Click on Test to test your selection.
7. Make any necessary adjustments and then click on OK.

Only the selected portion of the video clip will be played during a frame 
preview or when the presentation is played.

For more precise selection of a start or end point, you can use the Set 
Start and Set End buttons. 

1 Click on the Play button to start the video clip playing.
2. When you have reached the point where you would like the clip to 

start, click on the Set Start button. The start offset will appear in 
the Start Offset list box.

3. Continue playing the video clip until you reach the spot where you 
would like the clip to end. Click on the Set End button. The end 
offset will now appear in the End Offset list box.

4. Use the Test button to test your selection. Click on OK.

Note:
Using the methods described above, a selection can be made of any
video, animation, sound or music clip.


